Page 1 of 1

Enclosure lights flash then turn off

PostPosted: February 2nd, 2018, 2:10 am
by PotatoPants
I've not had any luck trying to figure out what is going on with my enclosure.

See google drive video for what is happening (Or the picture) - but when the power button is pressed, the lights will turn on for a second then immediately turn off. I've tried this and able to reproduce it with:

- Computer plugged in (USB 3.0) and not plugged in.
- 0,1,2,3,4 hard drives installed
- Different power outlets

Note:
- The green power brick light is on, although it does seem to be flickering/dimming very faintly.
- the lights also flash when the enclosure is plugged in.

Any ideas as to what is going on? Help would be greatly appreciated.

Re: Enclosure lights flash then turn off

PostPosted: February 6th, 2018, 1:02 pm
by Admin_Mediasonic
If you just bought it
return to place of purchase for exchange

Re: Enclosure lights flash then turn off

PostPosted: February 7th, 2018, 6:34 am
by PotatoPants
Sadly I bought this off Amazon Late 2015; with fairly light use - mainly as a backup and media storage solution

Re: Enclosure lights flash then turn off

PostPosted: February 12th, 2018, 2:32 am
by PotatoPants
Sorry so does that mean that it is broken? Will I have to get a new enclosure?

Re: Enclosure lights flash then turn off

PostPosted: April 18th, 2018, 8:25 pm
by bigmac182
I am having the exact same problem but mine will eventually light up but wont connect. Looks like its dead in 14 months. Thats unacceptable. I will be looking else where for storage.