K32-SU3 Rev.2 not working

Support and Discussion for 3.5" & 2.5" Enclosures - for PC Users
HD6-SU3, HD6-SU3S2, HD3-SU3, K32-SU3, H21-SU3 and HDK-SU3 (BN, PK and WT)

K32-SU3 Rev.2 not working

Postby PCHEFLIN » August 9th, 2017, 3:47 pm

I got two K32-SU3 Rev.2 from Amazon 08-09-17 (ser #: I17030622 and I17030623) to be used on Win10 Home. One with a Seagate ST500DM000 5tb drive and the other with a Toshiba MD04ACA500 5tb drive, both known good.

After install of drives in the enclosures, connection to pc and power I get nothing, no power lamps, pc does not see them (obviously w/o power). Any clue on what the problem could be? Drives worked in old enclosures that I no longer have. Power bar I'm using works fine, that's a known.
PCHEFLIN
 
Posts: 2
Joined: August 9th, 2017, 3:18 pm

Re: K32-SU3 Rev.2 not working

Postby paulcopen » August 9th, 2017, 7:39 pm

I did same thing as you did, I just bought the enclosure from amazon, it arrived today 8/9/17 and I have same problem?
My laptop And Desktop recognize it, but I cant access it and the drive light goes out after computer boots up?
paulcopen
 
Posts: 3
Joined: August 9th, 2017, 7:32 pm

Re: K32-SU3 Rev.2 not working

Postby paulcopen » August 9th, 2017, 7:41 pm

I tried 2 power supplies, 2 different drives 2 different computers, and 2 different USB 3 cables.
Same problem no lit, can.t access
paulcopen
 
Posts: 3
Joined: August 9th, 2017, 7:32 pm

Re: K32-SU3 Rev.2 not working

Postby PCHEFLIN » August 9th, 2017, 7:57 pm

I don't even get a light on ether unit, nothing, computers, laptop or desktop don't see it, even tried an xbox one.
PCHEFLIN
 
Posts: 2
Joined: August 9th, 2017, 3:18 pm

Re: K32-SU3 Rev.2 not working

Postby paulcopen » August 9th, 2017, 8:06 pm

update

I got my enclosure to work

In order to get your enclosure to work the drive you put in it has to be activated, and formatted.

in windows 10 use disk management, go to computer, click on manage and then click on disk management, find the drive, activate it, spawn it and format it.

I'm going to purchase another one for my other WD 2TB HD.
paulcopen
 
Posts: 3
Joined: August 9th, 2017, 7:32 pm

Re: K32-SU3 Rev.2 not working

Postby coyoteandraven » October 12th, 2017, 8:34 pm

k32-SU3 Rev.2 not working too
I have about 2 TB saved on the external drive which just stopped working
I have the same problems as you but I use a macbook pro El Capitan 10.11.6
sometimes the light in the enclosure is green sometimes it is amber but the hard drive inside (toshiba) does not show up on my desktop anymore
what do I do if it is a hardware problem? take it back to NCIX I started using it after the warranty was already finished thank you
coyoteandraven
 
Posts: 1
Joined: October 12th, 2017, 8:14 pm


Return to USB 3.0 Single Bay Enclosures - for PC Users

Who is online

Users browsing this forum: No registered users and 2 guests