ProBox K32-SU3 Issues - No power to drives and not USB3

Support and Discussion for 3.5" & 2.5" Enclosures - for PC Users
HD6-SU3, HD6-SU3S2, HD3-SU3, K32-SU3, H21-SU3 and HDK-SU3 (BN, PK and WT)

ProBox K32-SU3 Issues - No power to drives and not USB3

Postby ITGuy1024 » September 23rd, 2016, 10:42 pm

Hi,

Unfortunately I have some issues with my new ProBox K32-SU3. The first issue is that my W7 computer does not even see the enclosure unless it's on a USB 2 port. I am using the provided USB 3 cable in a USB 3 port but it does nothing (not even a windows ding) until I put it in a USB 2 port.

Next issue is that it does not power up a 3TB Seagate Constellation drive. Smaller Seagate 500GB drive powers up fine.

Any idea on these?
ITGuy1024
 
Posts: 2
Joined: September 23rd, 2016, 10:39 pm

Re: ProBox K32-SU3 Issues - No power to drives and not USB3

Postby Admin_Mediasonic » September 27th, 2016, 2:49 pm

what is the serial # on your enclosure?
Admin_Mediasonic
Site Admin
 
Posts: 1756
Joined: January 28th, 2010, 3:29 pm

Re: ProBox K32-SU3 Issues - No power to drives and not USB3

Postby ITGuy1024 » September 27th, 2016, 5:33 pm

16040856
ITGuy1024
 
Posts: 2
Joined: September 23rd, 2016, 10:39 pm

Re: ProBox K32-SU3 Issues - No power to drives and not USB3

Postby Admin_Mediasonic » September 30th, 2016, 6:15 pm

Hi
if you just bought it not long ago, please return to place of purchase for exchange
we know K32-SU3 can support 8TB drive, so is strange that it can't power your 3TB Constellation drive.
Admin_Mediasonic
Site Admin
 
Posts: 1756
Joined: January 28th, 2010, 3:29 pm


Return to USB 3.0 Single Bay Enclosures - for PC Users

Who is online

Users browsing this forum: No registered users and 2 guests

cron